After Update Rollup 12 was released for Microsoft Dynamics CRM 2011, we noticed a few quirks. Yesterday we talked about not being able to convert a lead after the update. Here’s another one for you: we noticed that in some situations after the update, the case entity’s ribbon was missing. Intriguing!

Luckily, this only applies to the case entity where the ribbon has been customized.

So, is your case ribbon missing? If so, here’s a quick tip to get the ribbon back.

case ribbon missing - UR 12

We need to disable the form assistant from the case.

Go to Settings > Customizations > Customize the System > Entities > Cases > Forms > Main > Form Properties > Select the Display Tab. (Whew!) Then uncheck the Enable Form Assistant.

Now we test! Refresh your browser, Go to Cases > Open Case record, and check to see if the ribbon appears.

Note: the Form assistant has been disabled.

Hope this trick resolves this minor issue! If this was helpful, you might want to check out our other blogs related to UR 12/Polaris:

Happy CRM’ing!

  • ram

    Hi joe,

    I have same Ribbon issue in Address entity form after applying rollup12. To perform the steps explained by you,
    we do not have Form assistant section to uncheck Enable form assistant. So how to resolve this issue?

    • alexfagundes

      Hi Ram – I’d recomend exporting your customizations, then checking if you see the form assistance in the xml set to true. If so, then set to false and re-import. We have seen something similar and the fix was to fix via the xml customizations.

  • Enterprise CMS

    After the release of Update Rollup 12 for MIcrosoft Dynamics CRM there are issues. Thanks for sharing this issues as it will be helpful to others.

  • Carol

    I installed the MS Dynamics CRM 2011trial and the ribbon does not appear to me at all.
    Do I have to run the rollups to see the ribbon?
    Tks!

    • alexfagundes

      Hi – do you have the latest and greatest update rollup installed? Also – check for missing microsoft office updates.

  • watley

    Hi, we are currently just rollup to 14, but we still came across this issue. It is inconsistent though as some of the existing case forms work fine except for new case form. We had tried all the steps provided by you above but it does not solve the issue. Are you able to advise us? Thanks in advance

    • alexfagundes

      Hi – one potential cause is that your browser still has an old js file. try to clear you cache. And is your issue inside the outlook crm client or web client too ?

Return to Top ▲Return to Top ▲