POWEROBJECTS

718 Washington Ave. N. Suite #101
Minneapolis, MN 55401
View map and all Locations

Send us a message

Recently one of our clients came across an issue in CRM 2011 Online, where sub-grids that had been added to their Forms were not displaying correctly. When creating a new record, the sub-grid would show up with the correct columns displayed but as soon as the record was saved, the sub-grid would change to a grey box with nothing in it!

In addition, users were getting a script error on the page when they tried to navigate away from the record.

The error looks something like this:

Microsoft Dynamics CRM Error Report Contents

<CrmScriptErrorReport>

<ReportVersion>1.0</ReportVersion>

<ScriptErrorDetails>

    <Message>Type mismatch</Message>

    <Line>1</Line>

    <URL>/userdefined/edit.aspx?_gridType=4&etc=4&id=%7b6435788C-2477-E011-8D96-1CC1DEE89AA8%7d&pagemode=iframe&rskey=664806187&sitemappath=Workplace%7cSFA%7cnav_leads</URL>

    <PageURL>/userdefined/edit.aspx?_gridType=4&etc=4&id=%7b6435788C-2477-E011-8D96-1CC1DEE89AA8%7d&pagemode=iframe&rskey=664806187&sitemappath=Workplace%7cSFA%7cnav_leads</PageURL>

    <Function></Function>

    <CallStack>

    </CallStack>

</ScriptErrorDetails>

<ClientInformation>

    <BrowserUserAgent>Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; OfficeLiveConnector.1.4; OfficeLivePatch.1.3; InfoPath.3; MS-RTC EA 2; .NET4.0C; .NET4.0E; Zune 4.7; MS-RTC LM 8)</BrowserUserAgent>

    <BrowserLanguage>en-us</BrowserLanguage>

    <SystemLanguage>en-us</SystemLanguage>

    <UserLanguage>en-us</UserLanguage>

    <ScreenResolution>1920×1080</ScreenResolution>

    <ClientName>Web</ClientName>

<ClientTime>2011-06-01T09:02:16</ClientTime>

</ClientInformation>

<ServerInformation>

<OrgLanguage>1033</OrgLanguage>

<OrgCulture>1033</OrgCulture>

<UserLanguage>1033</UserLanguage>

<UserCulture>1033</UserCulture>

<OrgID>{CB6C920B-43E1-407B-AC7F-F8A19F7256CA}</OrgID>

<UserID>{749161D8-8D35-4C6D-B5F7-35B751B12219}</UserID>

<CRMVersion>5.0.9688.1055</CRMVersion>

</ServerInformation>

</CrmScriptErrorReport>

Resolution: Enable native XMLHTTP support in the Security section of the Advanced Tab in internet options.

Hope this helps someone out there – If you are looking to connect with Microsoft CRM Experts – please reach out.

Happy CRM’ing

JoeCRM

Joe CRM is a CRM superhero who runs on pure Microsoft Dynamics CRM adrenaline. As the face of PowerObjects, Joe CRM’s mission is to reveal innovative ways to use Dynamics CRM and bring the application to more businesses and organizations around the world.